20 нояб. 2009 г.

Lenny + hplip 3.9.10

Дабы установить свеженький hplip, который я хочу заюзать для печати HP LaserJet P1005 (foo2xqx почему то бледнит), необходимо запускать инсталлятор 1) от пользователя, имеющего право на su; 2) сделать ему export LANG=C, иначе установщик не может принять пароль суперпользователя.
Хрен знает почему. Баг, видимо. Но предложенное решение работает.
А еще эта ересь не в состоянии сразу выдать список того, чего ему не хватает для установки. Выдает по одному наименованию за раз. И это при том, что говорит, мол де, нужно 6 зависимостей удовлетворить, вот тебе первая. Приходи за второй, блять...
Короче говоря, нужно еще поставить вот что:
  • python2.5-dev
  • libcups2-dev
  • libusb-dev
  • libtool
  • libcupsimage2-dev
Это на моей системе, где уже что-то когда то собиралось (те же ядерные модули), так что в иных случаях этот список может быть длиннее.