22 сент. 2011 г.

Debian + USB ADSL modem

Совершенно внезапно словил "зов из прошлого" - потребовалось завести под Debian-ом старый-старый USB ADSL модем. Так как они все на Conexant-овском чипе, то и заводятся идентично. Вся проблема - найти фирмварь для ядерного модуля (да-да, в ядре уже давно все, как в Греции). Здесь мне помог вот этот ресурс. Более того, там описан и весь процесс установки и настройки сего девайса. В общем, читаем, смотрим, настраиваем. Единственное, что там не описано, на появившийся псевдо-интерфейс (nas0) следует навесить какой-нибудь IP-адрес, иначе pppoe-discovery не сможет корректно отработать.

11 сент. 2011 г.

Отметился в проекте LinuxCounter (LiCo), который, по словам opennet-a, возродился и переписался. Добавил и ссылку на lico-профайл в нижней части страницы блога, рядом с godville-ским информером. Join & Enjoy!
Что делает LinuxCounter? Как можно догадаться из названия, он считает линуксы ;). А именно, пользователей и машины. Таким образом собирается статистика о количестве пользователей различных дистрибутивов (да-да, список дистрибутивов, доступных при заполнении анкеты машины, впечатляет), их географическая привязка, используемое железо и так далее и тому подобное. Обещаются вкусные и красивые графики и отчеты. 
Да и просто почесать свое ЧСВ, как без этого.

Gmail + MTA

Оставлю-ка я это здесь - годный пост о настройке различных МТА для работы с внешним смартхостом (gmail в данном случае). От себя добавлю, что работает акк не только @gmail.com, но и GoogleApps.

5 сент. 2011 г.

NVIDIA Driver problem workaround

При возникновении после обновления системы ошибки в процессе загрузки X-сервера вида
[  1018.694] (II) LoadModule: "nvidia"
[  1018.694] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  1018.694] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1018.694]     compiled for 4.0.2, module version = 1.0.0
[  1018.694]     Module class: X.Org Video Driver
[  1018.694] ================ WARNING WARNING WARNING WARNING ================
[  1018.694] This server has a video driver ABI version of 11.0 that this
driver does not officially support.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[  1018.694] =================================================================
следует добавить в секцию ServerLayout вашего xorg.conf следующую строку:
Option       "IgnoreABI" "true"