2 апр. 2014 г.

Cisco IDM + Java 7 application launch error

С выходом Java 7 (да-да, я в курсе, что уже восьмая версия зарелизилась) Oracle неплохо затянула гайки в вопросах безопасности. Одной из предпринятых мер стало отключение по умолчанию поддержки SSL 2.0, признанного небезопасным и устаревшим. Однако такой шаг может вызвать проблемы с работой целого ряда java-приложений для конфигурации всякого активного оборудования. К примеру, с java7 не работает Java Web Start приложение для управления Cisco IPS Device Manager. 
Решение: включить поддержку SSL 2.0
Control Panel > Java > Advanced > Security > General, поставить галку "Use SSL 2.0 compatible ClientHello format"