30 янв. 2015 г.

Postgresql-1C libicu46 mismatch

Не первый раз сталкиваюсь с косяком в разных дистрибутивах Debian при установке сборки Postgresql от 1С вида "для установки требуется libicu46 >= 4.6.1-1, а у вас версия отличается".
Рецепт лечения несложно найти на просторах Сети, но каждый раз ищется все дольше и дольше, поэтому скопирую для себя его тут (источник):

В общем нашел решение на просторах интернета, оно заключается в следующем:
  • копируем postgresql-contrib-9.2_9.2.4-1.1C_amd64.deb в папку на сервере, входим в нее;
  • распаковываем пакет: dpkg -x postgresql-contrib-9.2_9.2.4-1.1C_amd64.deb tmpdir 
  • После: dpkg -e postgresql-contrib-9.2_9.2.4-1.1C_amd64.deb tmpdir/DEBIAN 
  • Далее: открываем в текстовом редакторе файл «control»: nano ./tmpdir/DEBIAN/control
  • Ищем строку libicu46 (>= 1.4.6) и меняем ее на libicu52 (>= 1.4.6)
  • Сохраняем изменения и собираем пакет обратно: dpkg -b tmpdir postgresql-contrib-9.2_9.2.4-1.1C_amd64_fix.deb